An installation for Windows 7ΒΆ

  1. Install python 2.7 following the instructions at python.org.
  2. Install git following the instructions here.
  3. Install PostgreSQL (> 9.0) following the instructions at postgresql.org.

Note

Some python packages used by the clld software have extensions coded in C. If these packages are installed from source, the system must have a C-compiler. Without one, trying to install such a package results in the system complaining about vcvarsall.bat missing. The most straightforward way to fix this is to install the Microsoft Visual C++ Compiler for Python 2.7 (which requires setuptools 6.0 or later). You can find other solutions (using the MinGW compiler or Microsoft Visual Studio) explained in this stackoverflow thread.

Then follow the CLLD install instructions (Installation).